
 Activity 3.1 Worksheet 

Client Interview 

Team Name:__________________________________________________  Date: _______________________  

Client Name: _________________________________________________  

Interview Topics 

• Goals and target audience 

• Content 

• Design requirements 

• Delivery requirements 

Goals and Target Audience 

Identify three long-term goals of your website. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

What should the site inspire the audience to do after they visit? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Identify some immediate goals of your website. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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____________________________________________________________________________________________  

Name some key information you want the audience to gain from your site. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Describe content expectations of your target audience. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Other questions. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Audience Background 

Describe characteristics of your target audience. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

What is the age range of your target audience? 

____________________________________________________________________________________________  

 

What is the reading level of your target audience? 

____________________________________________________________________________________________  

 

Does your target audience have special requirements, such as disabilities? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

How often is your target audience online? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Describe the most common use of the web by your target audience. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 Client Interview   3 - 61 



Activity 3.1 Worksheet 

Use a few adjectives to describe how you want the target audience to perceive your site. (Examples: prestigious, 
friendly, corporate, fun, forward-thinking, innovative, cutting-edge, serious, crazy.) 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Other questions. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Content 

What should be the title of your site? 

____________________________________________________________________________________________  

 

What topics should be covered in your site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Other questions. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Design Requirements 

Are there any organization colors, fonts, graphics, or logos that should be included in the design? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Are there any colors or fonts you don’t want used on this site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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What are some websites you like? Describe specific elements you like about each site, such as navigation, colors, 
layout, and other design elements. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Other questions. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Delivery Requirements 

What browsers should this site support? 

• Netscape Navigator 

• Internet Explorer 

• AOL 

• Other: 

 

What platforms should this site support? 

• Macintosh 

• Windows 

• Other:
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Professional Web Design and Development Process 

When planning a web project, professionals break down the design and development process into phases such as the 
following. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Define 
Goals and audience 
Content/asset collection 
Delivery requirements 

Launch 
Promotion plan 
Site goes online 

Build and Test 
Site production 
Technical test 
Usability test 
Revision 
Test of revised site 
Final presentation 

Structure 
Flowchart 
Screen view sketches

Design 
Design comps 
Design review 
Redesign 
Production 
storyboard 

Redesign 
and Rework 

 

 

Note that this process builds in steps for review, redesign, and revision. 

 

Define Structure Design Build and Test Launch 

Goals and target 
audience 

Flowchart Design comps Site production Promotion plan 

Content and asset 
collection 

Screen view 
sketches 

Design review Technical test and 
bug list 

Put site online 

Content and style 
information 

 Redesign Usability test  

Delivery 
requirements 

 Production 
storyboard 

Revision  

   Test of revised site  

   Final presentation  

   Final revision  
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Project Plan 

Team Name:__________________________________________________  Date: _______________________  

Client Name: _________________________________________________________________________________  

Think through the phases of your client project and identify the date when each task will be done. Identify an owner 
for each task who will make sure the task is completed. 
 

Project Phases Estimated 
Hours Date Due Owner 

Define    

Goals and target audience    

Content and asset collection    

Content and style information    

Delivery requirements    

Structure    

Flowchart    

Screen view sketches    

Design    

Design comps    

Design review    

Redesign    

Production storyboard    
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Project Phases Estimated 
Hours Date Due Owner 

Build and Test    

Site production    

Technical test and bug list    

Usability test    

Revision    

Test of revised site    

Final presentation    

Final revision    

Launch    

Promotion plan    

Put site online    

Total Time:   = Final Deadline 
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Sample Screen Views 
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Production Storyboard 

Name: ______________________________________________________  Date: _______________________  

Site Name: ____________________  Page Title: ___________________ Filename:  
_____________________________  

Page sketch (everything specific to this page; common navigation elements optional)  

Background color (name and number) _____________________________________________________________  

Heading texts (fonts, styles, borders, margins, alignment, padding, and colors) _____________________________  

____________________________________________________________________________________________  

Body texts (fonts, styles, borders, margins, alignment, padding, and colors) _______________________________  

____________________________________________________________________________________________  

Description (what happens on the screen, such as order of display, text, and animation steps) 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Navigation (button or link names and destinations) ___________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Graphics files (all graphics specific to this page) _____________________________________________________  

____________________________________________________________________________________________  
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____________________________________________________________________________________________  
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Production Storyboard 

Name: D. Smith  Date: 08-02-05 

Site Name: Friends of the Golden Gate  Page Title: Golden Gate Home  Filename: index.html 

Page sketch (everything specific to this page; common navigation elements optional) 

 

 

 

 

 

 

 
Link Body Text Link Body Text Link Body Text 

Hours/Direction 

Tourist Info 

History 

Home Heading Text 

Body Text 

Image/Logo 

Background color (name and number): cream (#FFFCCC) 

Heading texts (fonts, styles, borders, margins, alignment, padding, and colors): Arial, 18 points, bold, left aligned, 6 
pixel padding on top and bottom, black text. 

Body texts (fonts, styles, borders, margins, alignment, padding, and colors): Body - Times New Roman, 11 points, 
left aligned, black text. Link Body - Times New Roman, 10 points, left aligned, dark brown text, underlined. 

Description (what happens on the screen, such as order of display, text, and animation steps): The navigation 
buttons will all turn a shade lighter when a site visitor rolls the pointer over one of them. When the pointer is not 
over any of the navigation buttons, they all display the same darker color. 

Navigation (button or link names and destinations): 

Home: Goes to index.html 

History: Goes to history.html 

Tourist Information: Goes to tourist.html 

Hours/Directions: Goes to hours.html 

Links: Each link will go to one of the following: 
San Francisco Museum (http://www.sfmuseum.org/assoc/bridge00.html) 
Geometry of Bridge Construction (http://www.faculty.fairfield.edu/jmac/rs/bridges.htm) 
Pictures of the Golden Gate Bridge (http://www.pcimagenetwork.com/golden/golden.htm) 

Graphics files (all graphics specific to this page): ggate_logo.png and ggate_logo.gif. 
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CSS Styles Panel in Dreamweaver 8 

Use the CSS Styles panel to create, view, apply, or edit CSS styles for elements of a web page. In the All mode, the 
panel has two panes: All Rules and Properties. 

 

 

 

 

Select a style to apply to the 
selected text in your 
document. 

Show Category View: View 
the properties of a style rule 
by property category. 

Show List View: View an 
alphabetical list of possible 
properties and those that 
compose the selected style 
rule. 

Show Only Set Properties: 
View a list of properties that 
compose the selected style 
rule. 

Unlink CSS Stylesheet/ 
Delete CSS Rule: Unlink the 
selected style sheet from t
document or remove a rule 
from a style sheet. When
you unlink style sheets 
delete rules, all the 
formatting associated with
the style sheet or rule is 
removed. 

he 

 
and 

 

Edit Style Sheet/Edit Style: 
Make changes to the style 
sheet linked to the 
document or styles in the 
current style sheet. 

New CSS Rule: Create a 
new style rule. 

Attach Style Sheet: Attach 
an external style sheet to 
your current document. 
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In the Current mode, the panel has three panes: Summary for Selection, About, and Properties. 

 

 

 

The Properties pane a
you to edit the rule’s 
properties and add new 

llows 

properties.

The About pane displays 
the location of the file that 
contains the rule defining 
the properties.

The Summary for 
Selection pane displays 
the CSS properties for the 
current selection in the 
document. 

 

3 - 78    



 Activity 3.6 Worksheet 

CSS Styles Panel in Dreamweaver 8 

Use the CSS Styles panel to create, view, apply, or edit CSS styles for elements in a web page. In the All mode, the 
panel has two panes: All Rules and Properties. Use the All Rules pane to apply styles to your document and the 
Properties pane to edit existing properties and add new properties to the selected style. 

Label the options available for creating and editing Cascading Style Sheets. 
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How to Create Cascading Style Sheets 

Cascading Style Sheets (CSS) are collections of formatting rules that control the appearance of content on a web 
page. By using style sheets, you can achieve greater consistency across your website (even if your site consists of 
only one page). CSS styles provide you with a wide range of options for formatting text. This guide shows you how 
to take advantage of Cascading Style Sheets both to maintain consistency and to apply characteristics to text—such 
as a border and background—that you can’t apply using the Property inspector alone. 

If you’ve been using Macromedia Dreamweaver 8, you may have been using CSS without knowing it. 
Dreamweaver formats all text with CSS by default. Every time you change certain text properties in the Property 
inspector, such as text size and text color, Dreamweaver defines a style for the text. Dreamweaver places these style 
definitions in the beginning of each web page’s code. A collection of these definitions is known as an internal style 
sheet, because it is contained within an individual web page. 

Internal style sheets are great for maintaining consistency within a document, but Cascading Style Sheets are 
especially useful for maintaining consistency across a number of different pages. By using an external style sheet—
a separate document that holds CSS style information—you can make sure that text appearance is consistent across 
multiple pages. Not only does a consistent appearance look more professional, but usability experts say that site 
visitors find what they’re looking for more easily on sites where text appearance is consistent. 
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Define CSS Styles 

You can define CSS styles in either of the following two ways: 

• You can redefine the properties of an existing HTML tag—such as Heading 1, Heading 2, or Paragraph. 
After you redefine a tag, the text you apply it to will maintain its new appearance when you apply it in the 
Property inspector.  

• You can define a new CSS style, known as a class. You can apply a CSS class to any text in your 
document. Its formatting will overrule the formatting applied to an existing tag.  

Whenever possible, redefine existing tags instead of creating new CSS styles. The existing tags provide a useful 
hierarchy for both you and the users of your site, and they also make it easier for people using screen readers to use 
your site. 

Redefine an existing tag 

1. Start Dreamweaver. 

2. Create a new HTML document. 

3. Save and name the Dreamweaver document. 

4. Type some text in the document. 

5. Select the text. 

6. Using the Property inspector, apply an HTML tag such 
as Heading 1 to the text. 

 The text appears in the default Heading 1 format 
(Figure 1).  

7. Make sure the CSS Styles panel is open. 

 If it is not, select Window > CSS Styles. 

8. To create a new style, click the New CSS Rule 
button (+) at the bottom of the panel (Figure 2). 

 The New CSS Rule dialog box opens (Figure 3). 

9. In Selector Type, select Tag.  

 This option lets you modify an existing tag. 

10. From the Tag pop-up menu, select h1 (the tag for 
Heading 1). 

11. In Define In, select This document only or New Style 
Sheet File.  

 This document only option defines the style as part of 
the document’s internal style sheet. New Style Sheet File
option defines the style as part of an external style sheet.

12. Click OK. 

 

Figure 1 Text with default Heading 1 tag applied 

 

 
 

Figure 2 CSS Styles panel 

 

Figure 3 New CSS Rule dialog box 

New CSS Rule button 
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 The CSS Rule definition dialog box opens with the 
Type category selected. The dialog box has the options 
listed below. (For more details, select Help > Using 
Dreamweaver.) 

 Type changes text properties such as font, size, and 
color. 

 Background controls background properties. For 
example, you can use a colored background or an 
image or create a fixed or scrolling background. 

 Block controls spacing and alignment of text and 
lines on the document. 

 Box changes the box that surrounds a block 
element. It affects properties such as height, width, 
padding, and margins. 

 Border changes the border properties around text, 
such as style, width, and color. 

 List controls list properties such as text type and 
bullet appearance. 

 Positioning defines text position on the page. 

 Extensions controls page breaks and the visual 
appearance of the cursor. 

13. Select options for Type, such as the following 
(Figure 5): 

 Select Verdana, Arial, Helvetica, sans-serif from 
the Font pop-up menu. 

 Select 15 from the Size pop-up menu, and leave 
pixels selected for the measurement unit (in the 
pop-up menu to the immediate right of the Size 
pop-up menu). 

 Type #006600 in the Color box, or select a color in 
the Color picker. 

 Note: All Heading styles are bold by default. If you 
don’t want the text to be boldface, select Normal from 
the Weight pop-up menu. 

14. Click Apply.  

 Observe that the Heading 1 text, or the text you chose, 
in the document has changed. (You may need to move 
the dialog box.) 

15. To change the background, select Background in the 
Category pane on the left. 

 The Background category of the CSS Rule definition 
dialog box opens (Figure 6). 

16. Select a color in the Color picker or type a hexadecimal 
number in the Background color dialog box, such as 
#CCCCCC. (Make sure the background color is lighter 
than the color of the text.) 

Figure 4 CSS Rule Definition dialog box  

 

Figure 5 CSS Rule Definition dialog box showing 
options for formatting text 

 

Figure 6 CSS Rule Definition dialog box showing 
background options 
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17. Click Apply to see your changes. 

18. To change the border and its properties, select Border 
in the Category pane. 

 The Border category of the CSS Rule Definition dialog 
box opens (Figure 7). 

19. Under Style, you can make changes such as deselecting 
Same for all and selecting solid from the Top pop-up 
menu. 

20. Under Width, you can make changes such as selecting 1
in the Top pop-up menu, and leaving pixels selected as 
the measurement unit. 

21. Under Color, you can make changes such as entering 
#006600, or whatever color you chose in step 13. 

22.  Click OK.  

 The CSS Rule Definition dialog box closes. 

 Observe that the appearance of Heading 1, or the text 
you chose, has changed (Figure 8).  

23. Make sure the CSS Styles panel is open. 

 If it is not, select Window > CSS Styles.  

24. Make sure that All is selected in the CSS Styles panel. 

 Observe that tag now appears under <style> in the All 
Rules area, indicating that this tag is part of the style 
sheet. Also observe that properties for this tag appear in 
the Properties area (Figure 9). 

25. To make further changes to the tag style, select it and 
click the Edit Style button.  

 The CSS Rule Definition dialog box opens. 

 Note: You can also make changes using the Properties 
area of the CSS Styles panel, but it is easier to make 
changes using the CSS Rule Definition dialog box. 

26. To apply the style to new text, select Heading 1, or the 
tag you modified, in the Text Property inspector. 

Figure 7 CSS Rule Definition dialog box showing 
options for formatting borders 

 

Figure 8 Text with new style formatting applied 

 

 
Figure 9 Style added to CSS Styles panel 
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Create a new style 

1. Start Dreamweaver. 

2. Create a new HTML document. 

3. Save and name the Dreamweaver document. 

4. Type some text in the document. Make sure that no 
formatting is applied to the text (Figure 10). 

5. Select the text. 

6. Make sure the CSS Styles panel is open. 

 If it is not, select Window > CSS Styles. 

7. To create a new style, click the New CSS Rule 
button (+) at the bottom of the panel. 

 The New CSS Rule dialog box opens (Figure 11). 

8. In Selector Type, select Class.  

 This option creates a new style. 

10. In the Name box, type a name for the style such as 
bold_red. 

11. In Define, select This document only or New Style 
Sheet File.  

 This document only option defines the style as part of 
the document’s internal style sheet. New Style Sheet File
option defines the style as part of an external style sheet.

12. Click OK. 

 The CSS Rule Definition dialog box opens (Figure 12).

13. Select the options for Type, such as the following 
(Figure 12):  

 Select Arial, Helvetica, sans-serif from the Font 
pop-up menu 

 Select 12 from the Size pop-up menu, and leave 
pixels selected for the measurement unit. 

 Type #CC0033 in the Color box, or select a color in 
the Color picker. 

16. To change the formatting of text blocks, select Block in 
the Category pane. 

 The Block category of the CSS Rule definition box 
opens (Figure 13). 

17. In the Letter Spacing box, you can make changes such 
as typing 3 and leaving pixels selected for the 
measurement unit.  

 This setting adds space between each letter. 

18. In the Text Indent box, you can make changes such as 
typing 5 and leaving pixels selected for the 
measurement unit.  

Figure 10 Text with no formatting applied 

 

Figure 11 New CSS Rule dialog box 

 

Figure 12 CSS Rule Definition dialog box 
showing Type options  

 

Figure 13 CSS Rule Definition dialog box 
showing options for formatting text blocks 
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 This indents the first line of each paragraph. 

19. Click OK. 

 The CSS Rule Definition dialog box closes. 

20. Select the document text. 

21. Make sure the Property inspector is open.  

 In Windows, it is docked at the bottom of the screen. If 
the Property inspector is not open, select 
Window > Properties. 

22. Select bold_red, or the name of your style, from the 
Style pop-up menu (Figure 14). 

23. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once. 

 Observe that the format of the text has changed 
(Figure 15). 

24. Make sure the CSS Styles panel is open. 

 If it is not, select Window > CSS Styles.  

25. Make sure that All is selected in the CSS Styles panel. 

 Observe that the newly created style, now appears under 
<style> in the All Rules area, indicating that style is part 
of a CSS style sheet. Also observe that properties for the 
style appear in the Properties area. 

26. To make further changes to the style, select it and click 
the Edit Style button.  

 The CSS Rule Definition dialog box opens. 

 Note: You can also make changes using the Properties 
area of the CSS Styles panel, but it is easier to make 
changes using the CSS Rule Definition dialog box. 

Figure 14 Text Property inspector 

 

Figure 15 Formatting applied to text 
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Export a Style Sheet 

You can convert an internal CSS style sheet to an external one by exporting it, removing the internal CSS style 
sheet, and attaching the exported CSS style sheet to one or more web pages.  

Export a style sheet 

1. Make sure the CSS Styles panel is open. 

 If it is not, select Window > CSS Styles.  

2. Make sure that All is selected in the CSS Styles panel. 

3. Under All, select <style>. 

4. Right-click (Windows) or Control-click (Macintosh) 
and select Export. 

 The Export Styles as CSS File dialog box opens 
(Figure 17). 

5. Browse to a location for the CSS file, enter a name for 
the file, and click Save. 

 Note: It is good practice to place CSS files in their own 
folder, often called CSS. 

 Dreamweaver exports the CSS file. 

 

 

 
Figure 16 CSS Styles panel 

 

 
Figure 17 Export Styles as CSS File dialog box 

 Delete an internal style sheet 

6. In the CSS panel under All, select <style>. 

7. Click the Delete Embedded Stylesheet button 
(Figure 18). 

 Dreamweaver removes the internal style sheet. Any text 
in your page that has been formatted with these styles 
reverts to its default formatting. 

 

 

 
Figure 18 Delete Embedded Stylesheet button 
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Attach an External Style Sheet 

It’s preferable to use external style sheets, especially if you have more than one web page. Once you create an 
external style sheet and attach it to multiple documents, you can instantly change any style in all your documents by 
making changes to the external style sheet. 

Note: Once you start using an external style sheet, it is best to make all text formatting changes through that style 
sheet. If you make formatting changes through the Property inspector, Dreamweaver will automatically create a new 
internal style sheet. 

1. Open a document. 

2. Make sure the CSS Styles panel is open. 

 If it is not, select Window > CSS Styles. 

3. Click the Attach Style Sheet button (Figure 19). 

 The Attach External Style Sheet dialog box opens 
(Figure 20). 

4. Click Browse, navigate to your saved style sheet, select 
it, and click OK (Figure 21). 

 
 

Figure 19 Attach Style Sheet button 

 

 
Figure 20 Attach External Style Sheet dialog box

 

 
Figure 21 Selecting a CSS style sheet to attach 

Attach Style 
Sheet
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5. In the Attach External Style Sheet dialog box, click OK 
(Figure 22). 

 Dreamweaver attaches the style sheet to your document 
(Figure 23). 

 The style sheet’s styles are now available in the Property
inspector. 

 You can attach the same style sheet to multiple 
documents. When you make changes to the style sheet, 
those changes will appear in all documents the style 
sheet is attached to. 

Figure 22 Confirming style attachment 

 

 
Figure 23 Attached style sheet 
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Create External Style Sheets 

You can also create external style sheets.  

1. Start Dreamweaver. 

2. Create a new HTML document. 

3. Save and name the Dreamweaver document. 

4. Make sure the CSS Styles panel is open (Figure 24). 

 If it is not, select Window > CSS Styles. 

5. To create a new style, click the New CSS Rule 
button (+) at the bottom of the panel. 

 The New CSS Rule dialog box opens (Figure 25). 

6. In the New CSS Rule dialog box, type a name for the 
style sheet. 

7. Select one of the following types of styles: 

 Class (can apply to any tag). Make your own 
HTML tag by naming a new style and defining its 
formatting. 

o In the New CSS Rule dialog box, select Class 
for Selector Type. 

o For Name, type the name of your style. 

Note: Class names typically begin with a 
period and do not have spaces or special 
characters. Example: .boldredtext (Figure 26). 

 Tag (redefines the look of a specific tag). Change 
the default format of any tag in a document. 

o In the New CSS Rule dialog box, select Tag 
for Selector Type. 

o From the Tag pop-up menu, select the type of 
tag to redefine (for example, H1 tag, body, or 
table) (Figure 27). 

 

 
Figure 24 CSS Styles panel 

 

 
Figure 25 New CSS Rule dialog box 

 

 
Figure 26 Create your own HTML tag (class) 

 

 
Figure 27 Modify an existing tag 

 

3 - 90   How to Create Cascading Style Sheets 



 Activity 3.6 Guide 

 Advanced (IDs, pseudo-class selectors, etc.). You 
can create various styles for links. 

o In the New CSS Rule dialog box, select 
Advanced for Selector Type. 

o From the Selector pop-up menu, select link 
characteristic you want to change (Figure 28). 

 Link controls the normal state of the link. 
The default color is blue. 

 Visited controls the link format after a 
visitor has clicked it. The default color is 
purple. 

 Hover controls the link format as the 
mouse moves over the link. The default 
color is red. 

 Active controls the link format while it is 
being clicked. The default color is red. 

8. For Define In, select New Style Sheet File. 

9. Click OK. 

 The Save Style Sheet File As dialog box opens 
(Figure 29). 

10. Name and save the style sheet in your local root folder. 

11. Make sure Site Root is selected in the Relative To box. 

12. Click Save. 

13. Use the CSS Rule Definition dialog box to set the 
formats for the new style. 

14. Click OK. 

 The new external style sheet is automatically attached to 
the current document and listed in the CSS Styles panel 
(Figure 30). 

 

Figure 28 Create an Advanced rule 

 

 
Figure 29 Save Style Sheet File As dialog box 

 

 
Figure 30 New external style sheet 

Style 
sheet
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Edit Styles 

1. To view a style sheet’s rules, click the plus symbol 
beside the style sheet you want to edit in the CSS Styles 
panel. 

 Dreamweaver displays style sheet’s rules.  

2. Select the rule you want to edit. 

3. At the bottom of the CSS Styles panel, click the Edit 
Style button (Figure 31). 

 The CSS Rule Definition dialog box for the selected 
style opens (Figure 32). 

4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK. 

 The changes take effect immediately. 

 
Figure 31 The Edit Style button 

 

 
Figure 32 Modifying CSS rule definitions 

Edit Style 
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How to Use Templates 

You can use a Macromedia Dreamweaver 8 template document to create multiple pages with the same layout. In a 
template, you control which page elements should remain constant in documents based on that template and which 
elements can be changed. Templates are helpful for building a website in which most pages have the same header, 
navigation system, and other elements. Using templates helps you save time as well as create and maintain a 
consistent look when more than one person is developing a site. 

Create a Template 

1. Start Dreamweaver. 

2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as 
tables (Figure 1). 

 Note: You may want to create navigation elements in 
Macromedia Fireworks 8 and export them as HTML 
documents. 

3. Select File > Save as Template. 

 Dreamweaver creates a Templates folder in your site 
root folder and saves your template in that folder. 
Template files have a .dwt file extension. 

Create an editable region 

Editable regions in a template are the parts of the page layout 
that can be changed in files based on the template. Locked 
(non-editable) regions are the parts of the page layout that 
remain constant from page to page. All regions in a new 
template are locked, so to make the template useful, you 
must make some regions editable. 

1. Position the insertion point where you want to insert an 
editable region in the template. 

 For example, you might want to use a table cell for 
content that is specific to each page—that is, content 
that changes from one page to another. 

2. Do one of the following to create an editable region: 

• Select Insert > Template Objects > 
Editable Region. 

• Right-click (Windows) or Control-click 
(Macintosh) the region and select Templates > 
New Editable Region from the context menu. 

• In the Common category of the Insert bar, click the 
Templates button (Figure 2), and select 
Editable Region from the pop-up menu. 

The New Editable Region dialog box opens (Figure 3).

Figure 1 Common elements on a web page 

 

 

Figure 2 Templates pop-up menu 

 

 
Figure 3 New Editable Region dialog box 

Templates 
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4. In the dialog box, enter a unique name for the region, 
and click OK. 

 The editable region is enclosed in a blue rectangle on 
the template. 

 Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name. 

5. Close the template. 

Create a document based on a template 

Once you create a template, you can use it to create new 
documents. 

1. Select File > New. 

2. In the New Document dialog box, select the Templates 
tab. 

 The name of the dialog box changes to New from 
Template (Figure 4). 

3. In the Templates For list, select the site that contains the 
template you want to use. 

4. Select the template you want to use. 

5. Make sure the Update page when template changes 
option is selected. 

 With this option selected, Dreamweaver can update all 
template-based pages if you change the template later. 

6. Click Create to create a new template-based page. 

 The document opens in the Document window. 

 
Figure 4 Templates tab in the New from Template 
dialog box 

Edit a Template 

You can edit a template at any time, even if you have created pages based on the template. 

1. Select Window > Assets. 

 The Assets panel opens. 

2. Click the Templates button on the left side of the panel 
(Figure 5). 

 A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to 
see this.) 

3. Select the template you wish to edit and do one of the 
following: 

• Double-click the name of the template. 

• Click the Edit button at the bottom of the panel 
(Figure 6). 

 
Figure 5 Templates button in Assets panel 

 

 
Figure 6 Edit button in Assets panel 

Edit 

3 - 94   How to Use Templates 



 Activity 3.7 Guide 

4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired. 

5. Save the edited template by choosing File > Save. 

 The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 7). 

6. Click Update to update the documents based on the 
changes you made in your template. 

If you have renamed or deleted any editable regions, the 
Inconsistent Region Names dialog box opens 
(Figure 8). It lists the regions in the documents based 
on the template that no longer exist in the template. 

Note: If you have enabled check in/check out, and the 
files to be updated are currently checked in, 
Dreamweaver asks to check these out before it can 
update them. 

7. Select a region from the list. 

8. From the Move content to new region menu, select a 
new region in which you want to place the content from 
the selected region (Figure 8). 

9. Repeat steps 7 and 8 for the remaining regions in the 
list. 

10. Click OK. 

 The Update Pages dialog box displays a summary of the 
updates performed (Figure 9). 

11. Click Close. 

 
Figure 7 Update Template Files dialog box 

 

 
Figure 8 Inconsistent Region Names dialog box 
with Move Content to New Region menu 

 

 
Figure 9 Update Pages dialog box 

Delete a Template 

1. Select the template in the Assets panel. 

2. Click the Delete button (trash can icon) at the bottom of 
the panel and confirm that you want to delete the 
template. 

 The template file is deleted from your site. 

 Documents that were based on a template you have 
deleted retain the structure and editable regions the 
template file had before you deleted it. To turn such a 
document into a normal HTML file without editable or 
locked regions, you must detach it from the template. 

 

 How to Use Templates   3 - 95 



Activity 3.7 Guide 

Detach from a Template 

To remove the template structure and constraints from a document based on a template, you can detach the 
document from the template. When a document is detached from its template, you can edit any element, including 
the regions that were previously locked. 

1. To detach a document from a template, open the 
document. 

2. Select Modify > Templates > Detach from Template.
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How to Use Libraries 

You can use a Macromedia Dreamweaver 8 library to store page elements such as images, text, sounds, or tables 
you want to reuse throughout your website. When you insert a library item, Dreamweaver actually inserts a link to 
the library item. If you later need to make changes to a library item, such as changing some text or an image, 
updating the library item automatically updates each instance of the item on every page into which you’ve inserted 
it. 

Create a Library Item 

1. Select an element of a document (such as an image or 
text) to save as a library item. 

2. Select Window > Assets, click the Library button, and 
then click the New Library Item button at the bottom 
right of the Assets panel (Figure 1). 

3. Enter a name for the new library item: Make sure 
Untitled is selected, type a name, and press Enter 
(Windows) or Return (Macintosh) (Figure 2). 

 Each library item is saved as a separate file (with the file 
extension .lbi) in the Library folder of the site’s local 
root folder. 

 

 
Figure 1 Library and New Library Item buttons 

 

      
Figure 2 Naming a new library item 

New Library Item New Library Item 

Insert a Library Item 

1. Position the insertion point in the Document window 
where you want to insert a library item. 

2. Make sure the Library panel is open. If it is not, select 
Window > Assets and click the Library button on the 
left side of the Assets panel (Figure 3). 

 The Assets panel opens and shows the Library category.

3. Drag a library item from the Assets panel to the 
Document window, or select an item and click the 
Insert button at the bottom of the panel. 

 

 
 

Figure 3 Library button 
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Edit a Library Item 

1. Select Window > Assets and click the Library button 
on the left side of the Assets panel. 

 The Library category of the Assets panel opens. 

2. Select a library item. 

3. Click the Edit button at the bottom of the Assets panel. 

 Dreamweaver opens a new window for editing the 
library item (Figure 4). This window is much like a 
Document window. You can tell it is a Library item by 
the .lbi filename extension on the document’s tab. On a 
Macintosh, the background is also gray. 

4. Edit the library item and then save your changes. 

 The Update Library Items dialog box opens, with a list 
of the files that use the library item (Figure 5). 

5. Click Update to replace the original library item with 
your edited version in the files that use the library item. 

 The Update Pages dialog box opens. 

6. To see a report on the updating process, make sure 
Show log is selected (Figure 6). 

7. Click Close. 

Figure 4 Library editing window 

 

 
Figure 5 Update Library Items dialog box 

 

 
Figure 6 Update report 
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Update All Documents to Use Current Library Items 

If you do not choose to update documents that use library items as you edit individual library items, you can later 
update all pages in the site with the current version of all library items. 

1. Make sure the library item with which you want to 
update documents is open. 

2. Select Modify > Library > Update Pages. 

 The Update Pages dialog box opens (Figure 7). 

3. From the Look In pop-up menu, select Entire Site, and 
then select the site name from the adjacent pop-up 
menu.  

4. Make sure Library Items is selected in the Update 
section.  

5. Click Start. 

 Dreamweaver updates the documents and provides a 
report on the updating process (Figure 8). If you have 
updated documents at the time you edited library items, 
this report confirms that no additional updating was 
required. 

6. Click Close. 
 

 
Figure 7 Update Pages dialog box 

 

 
Figure 8 Update Pages report 
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How to Add Flash Movies and Flash Video to a Website 

To add interest and interactivity, you can add Macromedia Flash movies and Flash video to your site. Flash movies 
contain Flash content, while Flash videos incorporate video from other sources, such as a video camera. For 
example, you might add an instructional Flash movie about model rocketry, or a slide show, or some video that 
documents a community event. 

Adding Flash Movies (SWF Files) 

1. Open Macromedia Dreamweaver 8 and open the 
document in which you want to insert a Flash movie. 

2. Make sure the Common category of the Insert bar is 
selected. 

3. Click the down arrow on the Media button and select 
Flash from the pop-up menu (Figure 1). 

 The Select File dialog box opens (Figure 2). 

4. Locate and select the Flash movie, and then click OK 
(Windows) or Choose (Macintosh). 

A Flash content placeholder, rather than a scene from 
the Flash movie itself, appears in your document 
(Figure 3). This is because the page is pointing to the 
Flash SWF file. When a visitor opens this page, the 
browser plays the SWF file. 

 

Figure 1 Flash button 

 

 
Figure 2 Select Flash movie 

 

 
Figure 3 Flash content placeholder 
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Set play options 

To determine how the movie plays when the page loads, you 
set options in the Property inspector (Figure 4). 

5. Make sure the Flash content placeholder is selected. 

6. In the Property inspector, select the Loop option to 
cause the movie to repeat as long as the visitor is on the 
page. 

7. Select the Auto play option to cause the movie play 
when the page loads. 

8. To test the movie, click Play. 

 Dreamweaver plays the Flash file in the document, 
showing you what visitors will see when they view the 
page in a browser. 

Figure 4 Flash Property inspector 

Adding Flash Video (FLV Files) 

Flash video plays like any other video content. When you add Flash video, Dreamweaver also inserts a set of 
playback controls. These controls appear in a browser when a visitor opens the page. 

1. Click the down arrow on the Media button on the Insert 
bar and select Flash Video from the pop-up menu 
(Figure 1). 

 The Insert Flash Video dialog box opens (Figure 5). 

2. Click the Browse button beside the URL text box. 

3. Locate and select the Flash video, and then click OK 
(Windows) or Choose (Macintosh). 

4. Make sure Progressive Download Video is selected in 
the Video Type menu at the top of the dialog box.  

 The Progressive Download Video option enables 
visitors to see movies as they download instead of 
waiting until after the entire movie has downloaded. 

 Note: The Streaming Video option requires the use of a 
Macromedia Communication Server. 

5. Click the Detect Size button to fill in the Width and 
Height boxes. 

 Dreamweaver requires this information to include the 
video. 

6. Select a skin from the Skin pop-up menu. 

 This determines the appearance of the Flash video 
playback controls (Figure 6). 

7. Select the Auto play option to cause the video to play 
when the page loads. 

8. Select the Auto rewind option to cause the video to 
rewind automatically when it reaches the end. 

Figure 5 Insert Flash Video dialog box 

 

Figure 6 Flash video in a browser with Clear Skin 
selected 
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9. Click OK to close the dialog box and insert the video. 

 A Flash Video placeholder appears in your document 
(Figure 7). 

10. Select File > Preview in Browser and select a browser 
from the submenu to preview the page and test the 
video. 

 
Figure 7 Flash Video placeholder 
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How to Check Files In and Out 

When you are working on a collaborative team, you can use Macromedia Dreamweaver 8 to check files in and out 
from local and remote servers. Checking out a file is like declaring “I’m working on this file now—don’t touch it!” 
When a file is checked out, Dreamweaver displays a checkmark next to the file’s icon in the Site panel and also 
displays the name of the person who checked out the file. Checking in a file makes the file available on the remote 
server to other team members to check out and edit at their workstations. Checking in also lets other team members 
see the changes you have made. 

Check Out Files 

Use the Site panel to check out files on a remote server. 

1. In the Files panel (Figure 1), select your local site from 
the Site menu. 

2. Click the Expand/Collapse button in the site panel 
(Figure 1). 

 You can now see your remote site and local site panes 
side-by-side (Figure 2). You can also toggle between 
these two windows when the Site panel is collapsed. 

3. Select one or more files in the Remote Site pane and 
click the Check Out File(s) icon at the top of the Site 
panel (Figure 2). 

 The Dependent Files dialog box opens (Figure 3). 

 Dependent files are files that are used or displayed in 
one of your selected files. 

4. To download dependent files along with the selected 
files, click Yes. Otherwise, click No. 

 Dreamweaver displays a checkmark beside each file you 
check out, along with your name. 

 

 
 

Figure 1 Files panel 

 

 

Figure 2 Files panel expanded to show remote site

 

Figure 3 Dependent Files dialog box 

Site menu Expand 
b tt

Check Out File(s) 
icon 
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Check In Files 

You can edit checked-out files on your workstation. When you finish working on checked-out files, remember to 
check them back in so other team members can access them. 

Use the Site panel to check in files to a remote server. 

1. In the Site panel, select your local site from the Site 
menu. 

2. Select one or more checked-out or new files in the Local 
Files pane of the site panel. 

3. Click the Check In icon at the top of the Site panel 
(Figure 4). 

 The Dependent Files dialog box opens (Figure 5). 

4. To check in dependent files along with the selected files, 
click Yes. Otherwise, click No.  

 Dreamweaver displays a lock in the Local Files pane 
next to each file you check in, and it clears the 
checkmark that was displayed in the Remote Site pane 
when you checked out the file (Figure 6). 

 Provided your site administrator has enabled it, you can 
view or print any locked file in the Local Files pane. 
The lock reminds you that you cannot edit the file and 
save it, however, unless you first check it out. 

5. Click the Expand/Collapse button to collapse the Files 
panel. 

 

Figure 4 Check In icon 

 

Figure 5 Dependent Files dialog box 

 

Figure 6 Checked in files 

Check In icon 

Undo Check Out 

Sometimes, after you check a file out and make changes to it, you may want to discard these changes. The Undo 
Check Out command enables you to check a file in without saving changes. 

1. In the Site panel, select your local site from the Site 
menu. 

2. Select one or more checked-out files in the Local Files 
pane of the site panel. 

3. Right-click (Windows) or Control-click (Macintosh) 
and select Undo Check Out from the context menu. 
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How to Create a Calendar 

The Calendar extension for Macromedia Dreamweaver 8 is a quick way to create an editable calendar. Uses include 
company calendars, school calendars, and community event listings that can be updated and changed easily.  

1. Download and install the Calendar Object extension 
from the Macromedia site: 
www.macromedia.com/exchange/dreamweaver/ 

 Note: To download free extensions, you need to be a 
Macromedia member. Membership is free. To fined the 
Calendar Object, you may need to click the Search 
Exchanges button and enter Calendar Object as the 
keyword for your search. The Calendar Object 
extension is free to download. 

2. Start Dreamweaver. 

3. Select Insert > Calendar. 

 The Insert Calendar dialog box opens (Figure 1). 

4. Set preferences as you choose in the Insert Calendar 
dialog box. 

5. Click OK. 

 The calendar month appears in the document. 

6. To add information to a day, click in its cell and type. 

Figure 1 Insert Calendar dialog box 
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How to Create Forms 

You can use forms to interact with or gather information from site visitors. With forms, visitors can provide 
feedback, sign a guest book, take a survey, or place an order for merchandise. In Macromedia Dreamweaver 8, you 
can create a variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, 
and clickable images (such as a Submit button). 

The Forms category on the Insert bar contains buttons for creating forms and inserting form elements. 

 
Figure 1 Forms category on the Insert bar 

The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form 
processing, contact your web administrator. This guide helps you make the user interface of a form. 

Set Up the Form 

1. Open a page in Dreamweaver. 

2. Select the Forms category on the Insert bar (Figure 2). 

3. Place the insertion point on the page where you want to 
insert a form, and click the Form button (Figure 3). 

 A blank form appears, with a red dotted outline 
(Figure 4). You place all form elements inside this 
outline. 

 Form options appear in the Property inspector. 

4. From the Method pop-up menu in the Property 
inspector, select either GET or POST. 

• GET appends the form contents to the URL 
specified in the Action text box. 

• POST sends the form contents in the body of a 
message such as an e-mail message. 

5. In the Action text box, type the URL or CGI script that 
will process the form. 

 Note: Get this information from your web administrator.

 
Figure 2 Category menu on Insert bar 

 

 
Figure 3 Form button 

 

Figure 4 Blank form 
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Add Form Elements 

Using the Forms category on the Insert bar, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose. 

Using form fields 

Form fields enable site visitors to enter text into a form. Form fields include the following: 

• Text fields, in which a visitor types a response 

• File fields, in which a visitor types the path of a file to upload to your server 

Add a text field 

Text fields provide a space in which visitors can enter text. 

1. Click the Text Field button on the Insert bar. 

 The text field appears in the blank form (Figure 5). The 
Input Tag Accessibility Attributes dialog box opens. 

2. In the Input Tag Accessibility Attributes dialog box, 
enter a label for the text field. You can leave the other 
fields in the dialog box at their default values. 

3. Enter a unique name for the text field in the Property 
inspector’s Textfield text box. You may use any 
combination of letters, numbers, and an underscore (_). 

4. In the form Property inspector, select one of the three 
types of text fields: 

• Single line text for short answers 

• Multi line text for long answers such as the visitor’s 
description of a problem with a purchased item 

• Password text for passwords (in which asterisks 
appear in place of typed characters) 

 Note: You can also create a multiple-line text field by 
clicking the Text area button on the Insert bar. 

Figure 5 Example of text field 
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Add a file field 

A file field enables site visitors to select a file on their computers (such as a word processing document or graphics 
file) and upload it to your server. A file field looks like other text fields, except it also contains a Browse button. 
The visitor either types the path to the file they want to upload or uses the Browse button to locate and select the 
file. 

1. Click the File Field button on the Insert bar. 

 The file field appears in your document (Figure 6). 

2. In the Property inspector’s FileField Name text box, 
enter a name for the file field object. 

3. In the Char Width text box, specify the maximum 
number of characters visitors will see in the field. 

4. In the Max Char text box, specify the maximum number 
of characters the field will hold. 

 Note: Contact your web administrator to confirm that 
anonymous file uploads are allowed before using the file 
field. 

Figure 6 Example of file field 

Using Checkboxes and Radio Buttons 

Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can select one or more 
options from a group of options. With radio buttons, visitors can select only one option from a group of options. 

Add a checkbox 

1. Click the Checkbox button on the Insert bar. 

 The checkbox button appears in your document 
(Figure 7). 

2. In the Property inspector’s Checkbox Name text box, 
type a unique, descriptive name for the checkbox. 

3. In the Checked Value text box, enter a value for the 
checkbox. 

 This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes. 

4. For Initial State, select Checked if you want an option 
to appear selected when the form first loads in the 
visitor’s browser. 

Figure 7 Example of checkbox 
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Add a group of radio buttons 
Radio buttons are typically used in groups. 

1. Click the Radio Group button on the Insert bar to insert 
a group. 

 The Radio Group dialog box opens (Figure 8). 

2. Enter a name in the Name text box. 

3. Click the plus (+) button to add a radio button to the 
group. 

4. Enter a label and (if you want) a checked value for each 
button. 

5. Click the up or down arrows to reorder the buttons. 

6. Select Line breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table.  

7. Click OK. 

 
Figure 8 Radio Group dialog box 
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Using Lists and Menus (List/Menu) 
Lists and menus allow visitors to select options from a list or pop-up menu. With a scrolling list, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item 
from a pop-up menu. 

Add a scrolling list 

1. Click the List/Menu button on the Insert bar. 

 A list/menu field appears in your document (Figure 9). 

2. In the Property inspector, enter a unique name for the 
list in the List/Menu text box. 

3. For Type, select List. 

4. In the Height text box, enter the number of items the list 
will display. 

 If this number is less than the total number of items in 
the list, a scroll bar will be displayed. 

5. If you want to allow visitors to select more than one 
item in the list, select Allow Multiple for Selections. 

6. Click the List Values button to add the list items. 

 The List Values dialog box opens (Figure 10). 

7. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list. 

8. In the Value text box, enter data you want sent to the 
server when a visitor selects the item. 

9. To add another item to the list, click the plus (+) button.

10. When you finish, click OK to close the List Values 
dialog box. 

11. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Property inspector. 

Figure 9 Example of scrolling list 

 

 
Figure 10 List Values dialog box 
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Add a pop-up menu 

1. Click the List/Menu button on the Insert bar. 

 A List/Menu field appears in your document 
(Figure 11). 

2. In the Property inspector, enter a unique name for the 
list in the List/Menu text box. 

3. For Type, select Menu. 

4. Click the List Values button to add the menu items. 

 The List Values dialog box opens (Figure 12). 

5. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu. 

6. In the Value text box, enter data you want sent to the 
server when a visitor selects the item. 

7. To add another item to the menu, click the plus (+) 
button. 

8. When you finish, click OK to close the List Values 
dialog box. 

 Note: To see these values, you need to preview this 
page in a browser. 

9. To have one of the items in the menu selected by 
default, select that item in the Initially Selected text box 
in the Property inspector. 

Figure 11 Example of pop-up menu 

 

 
Figure 12 List Values dialog box 

Add a jump menu 

A jump menu is a pop-up menu with options that link to documents or files. You can create links to documents in 
your website or other websites, e-mail links, links to graphics, or links to any file type that can be opened in a 
browser. 

1. Click the Jump Menu button on the Insert bar. 

 The Insert Jump Menu dialog box opens (Figure 13). 

2. Complete the dialog box. 

 For more information, click the Help button in the 
dialog box. 

3. Click OK. 

 

Figure 13 Insert Jump Menu dialog box 
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Using Form Buttons 

Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser’s default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice. 

Add a standard text button 

1. Click the Button button on the Insert bar. 

 A text button field appears in the document (Figure 14).

2. Enter a name for the button in the Property inspector’s 
Button Name text box 

 Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values. 

3. In the Property inspector’s Value text box, enter the text 
you want to appear on the button. 

4. Select the type of Action. 

Figure 14 Example of text button 
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Add a graphical submit button 
You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel. 

1. Click the Image Field button on the Insert bar. 

 The Select Image Source dialog box opens (Figure 15).

2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Choose (Macintosh).

 The graphical submit button appears in your document 
(Figure 16). 

3. In the Property inspector, enter a unique name for the 
image in the ImageField text box. 

 Note: You can also click the folder icon beside the Src 
text box to select a new image for the button. 

4. In the Alt text box, type alternate text you want to 
appear in place of the image for text-only browsers. 

 
Figure 15 Select Image Source dialog box 
 

Figure 16 Example of graphical submit button 
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How to Create Image Maps 

An image map is an image that has been divided into regions, or hotspots. When a visitor clicks a hotspot on your 
site page, an action occurs; for example, another web page opens. An example is a geographic map that links each 
country in the map to another page in your site or an external website containing information about that country. 

Create an Image Map 

1. Open Macromedia Dreamweaver 8 and open the 
document in which you want to create an image map. 

2. Make sure the Common category is selected on the 
Insert bar (Figure 1). 

3. Click the down arrow on the Images button and select 
Image from the pop-up menu (Figure 2). 

 The Select Image Source dialog box opens. 

4.  Locate an image for the image map, select it, and click 
OK (Windows) or Choose (Macintosh). 

 The image is added to the page (Figure 3). 

5. Select the image in the Document window. In the 
Property inspector, type a name for the map in the Map 
text box. 

 Note: Naming conventions for image maps follow the 
same rules as filenames: no spaces or special characters.

Figure 1 Common category of Insert bar 

 

Figure 2 Images pop-up menu 

 

Figure 3 Image inserted 
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6. Select one of the hotspot tools located below the Map 
name, and draw a rectangle, circle, or polygon around a 
part of the image (Figure 4). 

7. In the Hotspot Property inspector (Figure 5), do the 
following: 

• Add a link to a page in your site or to an external 
URL. 

• Type a descriptive phrase for the link destination in 
the Alt text box. 

8. Repeat steps 6 and 7 to add other hotspots in the image 
map. 

9. Save the page. 

10. Select File > Preview in Browser and select a browser 
from the submenu to preview the page and test each 
link. 

 

Figure 4 Image map 

 

Figure 5 Hotspot Property inspector 

Image map 

Hotspot tools 
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How to Create Rollover Images 

A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: 
the primary image (the image displayed when the page first loads) and the rollover image (the image that appears 
when the pointer moves over the primary image). 

Rollover images add highlighting or design effects by drawing viewer attention when the images are swapped. One 
example is a button that highlights or changes color when the pointer passes over it. 

Create a Rollover Image 

1. Open Macromedia Dreamweaver 8 and open the 
document in which you want to create a rollover image.

2. Make sure the Common category is selected on the 
Insert bar. Click the down arrow on the Images button 
and select Rollover Image from the pop-up menu 
(Figure 1). 

 The Insert Rollover Image dialog box opens (Figure 2).

3. Use the Insert Rollover Image dialog box to set up your 
rollover: 

• Image Name: Type a name for the rollover image. 

• Original Image: Click Browse and select the image 
to be displayed when the page loads. 

• Rollover Image: Click Browse and select the image 
to be displayed when the pointer rolls over the 
original image. 

• Alternate text: Type the text you want to appear as 
alternate text for the image. 

• When Clicked, Go To URL: Click Browse and 
select the file (or type the path to the file) to be 
opened when the image is clicked. 

5. Click OK to close the dialog box. 

6. Save the page. 

7. Select File > Preview in Browser and select a browser 
from the submenu to preview the rollover image and test 
the link. 

 

Figure 1 Images pop-up menu 

 

Figure 2 Insert Rollover Image dialog box 
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How to Create Pop-up Menus 

Pop-up menus are menus that are displayed in a browser when a site visitor moves the pointer over or clicks a 
trigger image. Items in a pop-up menu can have URL links attached to them for navigation. 

You can use pop-up menus to display multiple links within a small space. They provide navigation flexibility 
without long download times. You can define the appearance of the pop-up menu so it matches the overall look and 
feel of your website. A pop-up menu is similar to a table: each menu item is like a table cell. You can customize the 
menu by choosing from a selection of font types, cell colors, and background image styles. 

Create Pop-up Menu Entries 

1. Open Macromedia Fireworks 8. 

2. Open or create the image that will trigger the pop-up 
menu. 

 Note: The trigger image may be a text object or a 
graphic. Be sure to set the canvas dimensions to account 
for the size of the pop-up menu; you can trim the canvas 
after you build the menu to adjust the size. 

3. Click the trigger image to select it. 

4. Select Edit > Insert > Rectangular Slice to insert a 
slice over the trigger image (Figure 1). 

 Note: To create a slice that is not rectangular, you can 
use the Polygon Slice tool. See Fireworks help for more 
information. 

When a slice is selected, a circle with cross hairs 
appears in the center of the slice. This is called a 
behavior handle. 

5. Click the behavior handle and select Add Pop-up Menu
from the context menu (Figure 2). 

 
Figure 1 Slice 

 

 

Figure 2 Behavior handle context menu 

Behavior handle 
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 The Pop-up Menu Editor opens (Figure 3). 

6. In the Content tab of the Pop-up Menu Editor, double-
click to place the insertion point in the first Text box 
(Figure 4). Enter the text for a menu item. Press Tab to 
move to the Link box, and enter the name of the file it 
links to. 

7. To add a new menu item, click the Add Menu (+) 
button and repeat step 6. 

8. To delete a menu item, select the item and click the 
Delete Menu (–) button. 

9. After you have entered all the menu items, click Next or 
click the Appearance tab. 

 
 

Figure 3 Pop-up Menu Editor  

 

Figure 4 Pop-up Menu Editor with menu entries 

Delete menu 
iAdd menu 

i
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Set the Appearance of a Pop-up Menu 

On the Appearance tab of the Pop-up Menu Editor, you can format the text, apply graphic styles to the Over and Up 
states, and select vertical or horizontal orientation for the pop-up menu. 

10. Select either HTML or Image for Cells (Figure 5). 

 Note: HTML sets the menu’s appearance using only 
HTML code; this setting produces pages with smaller 
file sizes. Image gives you a selection of graphic image 
styles to use as the cell background; this setting 
produces pages with larger file sizes. 

11. Select Vertical Menu or Horizontal Menu from the 
Orientation pop-up menu near the top of the Appearance 
tab. 

 Settings you choose immediately appear in the preview 
window near the bottom of the Appearance tab. 

12. Select font type, font size, and text styles for your menu 
items. 

13. Select text and background (Cell) colors for the Up state 
and the Over state. 

 These states are similar to button states. The Up state of 
a menu item is its default appearance in the menu. The 
Over state is the appearance of the menu item when the 
pointer passes over it. 

14. If Image is selected as the cell type, select a graphical 
style for the Up state and the Over state (Figure 6). 

15. Click Next or click the Advanced tab (Figure 7) if you 
want to change cell or border attributes. 

 

 
Figure 5 Appearance tab of Pop-up Menu Editor 

 

 
Figure 6 Graphical style for cells 

 

 
Figure 7 Advanced tab of Pop-up Menu Editor 
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Set the Position of a Pop-up Menu 

16. Click Next or click the Position tab in the Pop-up Menu 
Editor (Figure 8). 

17. Click a Menu Position button to position the pop-up 
menu relative to the trigger slice. 

 Note: Alternatively, you can enter X and Y coordinates. 
Coordinates of 0, 0 align the upper left corner of the 
pop-up menu with the upper left corner of the trigger 
slice. 

18. Click Done. 

19. To preview your pop-up menu, select File > Preview in 
Browser and select a browser from the submenu. 

 

 
Figure 8 Position tab of Pop-up Menu Editor 

Edit a Pop-up Menu 

1. To edit a pop-up menu, select the slice to which your 
menu is attached and double-click the pop-up menu’s 
blue outline in the workspace, or click the behavior 
handle and select Edit Pop-up Menu (Figure 9). 

 The Pop-up Menu Editor opens. 

2. Set options in the Pop-up Menu Editor just as you did 
when you created your pop-up menu. 

 

 
 

Figure 9 Behavior handle context menu 

Behavior handle 
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Export a Pop-up Menu for Use in Macromedia Dreamweaver 8 

To save the pop-up menu so it will be active on your website, export the document as HTML. 

1. While still in Fireworks, trim any excess canvas 
surrounding your image by choosing 
Modify > Canvas > Trim Canvas. 

2. Save the file. 

3. Select File > Export. 

 The Export dialog box opens (Figure 10). 

4. Navigate to the appropriate folder in your local root 
folder, such as Images. 

5. Give the pop-up menu a short, descriptive name. 

6. Select HTML and Images from the Save As type 
menu. 

7. Make sure the option Put Images in Subfolder is 
selected. 

 Note: Putting all the exported image files in a subfolder 
is a good way to manage those files. 

8. Click Export. 

9. Close Fireworks. 

Figure 10 Export dialog box 

Import a Pop-up Menu into Dreamweaver 

1. Start Dreamweaver. 

2. Open the document into which you want to import the 
pop-up menu. 

3. Position the insertion point where you want the pop-up 
menu to appear. 

4. Make sure the Common category is selected on the 
Insert bar. Click the down arrow on the Images button, 
and select Fireworks HTML (Figure 11). 

 The Insert Fireworks HTML dialog box opens 
(Figure 12). 

5. Click Browse and select the pop-up menu HTML file. 

 Note: The Images subfolder contains the sliced images 
for your pop-up menu. 

6. Click OK. 

 The pop-up menu is inserted into your Dreamweaver 
document. 

7. Select File > Preview in Browser and select a browser 
from the submenu to test the menu and the links for the 
menu items. 

Figure 11 Insert Fireworks HTML 

 

Figure 12 Insert Fireworks HTML dialog box 
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How to Prepare Photographs 

Presenting photos on a web page can be challenging because pictures have to work well with the text, colors, and 
design of the site. In Macromedia Fireworks 8, you can adjust the tone of photographs or mask them with shapes 
that work better with the overall design of the site. 

Masking Photographs 

Masks are bitmap or vector images placed on top of a photograph that leave visible only the part of the photograph 
that is inside the masking image. You can use masks to create cut-out effects or transparency effects on photos. 

Create a bitmap mask 

1. Start Fireworks and open the photograph to be masked 
(Figure 1). 

2. Select a drawing tool such as the Brush, Pencil, 
Rectangle, or Ellipse tool and draw a masking region on 
the photo (Figure 2). 

3. Select Edit > Cut to move the bitmap mask to the 
Clipboard. 

 
Figure 1 Photograph to be masked 

 

 
Figure 2 Bitmap mask 
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4. Select the photograph and select Edit > Paste as Mask.

 Only that portion of the photograph in the area outlined 
by the bitmap mask is visible (Figure 3). 

5. Click the image thumbnail on the Layers panel 
(Figure 4). 

A light blue handle appears in the image (Figure 5). 
You can use this handle to adjust the position of the 
image within the mask. 

6. Drag the image to rearrange its position under the mask.

7. Save the file as a Fireworks PNG. This will let you edit 
the mask later. 

8. Select Edit > Export to export the image as a JPEG or 
GIF file. 

 
Figure 3 Photograph visible through mask 

 

Figure 4 Image thumbnail on Layers panel 

 

 
Figure 5 Image with handle 
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thumbnail 

Handle 

3 - 128   How to Prepare Photographs 



 Activity 3.7 Guide 

Feather and add effects to masks 

1. Select the bitmap mask thumbnail in the Layers panel 
(Figure 6). 

2. In the Fill section of the image Property inspector, select 
Feather from the Edge menu (Figure 7) and increase 
the Amount of Feather. (Either type a higher number in 
the text box to the right of the Edge menu or click the 
down arrow and drag the slider.) 

 The edge of the mask is feathered (Figure 8). You can 
see the feathering better if you deselect the image.  

3. To add a Glow, select the image thumbnail (not the 
mask) on the Layers panel. 

4. In the Property inspector, click the Add Filters (+) 
button and select Shadow and Glow > Inner Glow 
from the pop-up menu (Figure 9). 

 The Inner Glow pop-up window opens (Figure 10). 

5. Increase the Offset and Width of the glow until you can 
see it in the masked image. 

6. Adjust the Softness, Opacity, and Color until you 
achieve the desired effect.  

7. When you finish, click outside the window or press 
Enter (Windows) or Return (Macintosh) to close the 
window. 

8. Save and export the image as a JPEG or GIF file. 

 
Figure 6 Bitmap mask thumbnail selected 

 

Figure 7 Image property inspector 

 

 
Figure 8 Feathered mask 

 

 
Figure 9 Add Filters pop-up menu 

 

 
Figure 10 Inner Glow pop-up window 
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Create a text mask 

1. Start Fireworks and open the photo to be masked. 

2. Create text to become the mask for the image 
(Figure 11). 

3. Adjust the text size and font and select Edit > Cut to 
move the text to the Clipboard. 

4. Select the photo and select Edit > Paste as Mask. 

 The image appears only in the area outlined by the text 
mask (Figure 12). 

5. Click the image thumbnail in the Layers panel 
(Figure 13). 

 A light blue handle appears in the center of the image 
(Figure 14). 

6. Drag the image center point to rearrange the position of 
the image under the mask. 

7. Save and export the image as a JPEG or GIF file. 

 
Figure 11 Text to mask image 

 

 
Figure 12 Photograph visible through text mask 

 

Figure 13 Image thumbnail selected 

 

 
 

Figure 14 Text mask with handle 
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Adjust the Color Tone of Photos 

1. Select the bitmap image for color adjustments. 

2. Select Filters > Adjust Color > Hue/Saturation. 

 The Hue/Saturation dialog box opens (Figure 15). 

3. Make sure the Preview option is selected. 

4. Drag the Hue, Saturation, and Lightness sliders to 
create the desired color feel for the photo. 

 Note: As an alternative to dragging a slider, you can 
type a number in the associated text box. 

5. To adjust the general color of the photo, select the 
Colorize option in the Hue/Saturation dialog box. 

6. To apply an antiqued look to the photo, select 
Commands > Creative > Convert to Sepia Tone. 

7. To make the photo black and white, select 
Commands > Creative > Convert to Grayscale. 

Figure 15 Hue/Saturation dialog box 
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 Activity 3.9 Worksheet 

How to Promote a Website 

Team Name:__________________________________________________  Date: _______________________  

Investigate how to use search engines on the web to promote a website. When you submit the URL for your site to a 
search engine, people can locate your site based on information you provide about your site. 

Go to www.searchenginewatch.com/webmasters/ for search engine submission tips. 

Find a search engine that offers free submission of websites. 

Site name and URL: ___________________________________________________________________________  

Submission procedure: _________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 
Find a search engine or promotion site for which you pay to submit your site. 

Site name and URL: ___________________________________________________________________________  

Cost to submit: _______________________________________________________________________________  

Submission procedure: _________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Is this search engine or promotion site worth the cost? Why or why not? __________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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